Simulasi Routing dalam Cisco Paket Tracer

Uncategorized

Routing adalah proses pengiriman informasi/data dari pengirim di suatu jaringan ke penerima yang berada di jaringan yang lain (melalui internetwork).Untuk dapat me-route paket, dibutuhkan Router
Agar dapat me-route paket, Router minimal harus mengetahui
1.Alamat (IP) Penerima
2.Router tetangganya, yang dengan itu ia bisa mempelajari jaringan lebih luas
3.Route/lintasan yang bisa dilewati
4.Route terbaik ke setiap jaringan
5.Informasi routing

Router mengetahui atau belajar mengenai jaringan yang jauh dari router tetangganya (atau dimasukkan secara manual oleh admin).Router membangun tabel routing untuk dapat mem-forwardkan data ke jaringan yang jauh

Ada beberapa jenis – jenis routing yang ada pada router :

1. Static Routing adalah routing yang administrator secara manual men-set tabel routing.
2. Default Routing adalah routing mengirim paket ke jaringan yang tidak ada di dalam tabel routing ke Router selanjutnya. Hal ini terjadi jika Router hanya mempunyai satu port keluar.
3. Dynamic Routing adalah routing yang terjadi proses pembelajaran oleh Router dan meng-update tabel routing jika terjadi perubahan. Pembelajaran dilakukan dengan komunikasi antar router-router dengan protokol-protokol tertentu.

Pada simulasi kali ini saya menggunakan Static Routing yang memiliki ciri-ciri :

1.Tidak membebani CPU
2.Tidak diperlukan komunikasi antar Router
3.Aman (krn hanya admin yg bisa men-setup)
4.Admin harus menguasai jaringan keseluruhan
5.Jika ada tambahan jaringan, admin harus menambahkannya pada semua Router

Saya mencoba untuk simulasi saat ini menggunakan jaringan seperti dibawah ini:

Terdapat 4 Network yaitu:

192.168.10.0

192.168.20.0

192.168.30.0

192.168.40.0

 

Pertama untuk mensimulasikan routing di cisco paket tracer saya disini membuat jaringan seperti ini :

Lalu untuk mengkoneksikan antar device pilih kabel Straight untuk Koneksi dari PC ke Switch dan dari Switch ke Router, untuk mengkoneksikan antar Router menggunakan Serial DTE. Dalam mengkonfigurasi untuk Static Routing perlu diingat interface yang telah terhubung.Saya disini telah membuat pembagian IP Address pada Router sebagai berikut : 

Router 0 

Interface FastEthernet0/0  : 192.168.10.1

Interface Serial2/0            : 192.168.1.1

Interface Serial3/0            : 192.168.4.2

 

Router 1

Interface FastEthernet0/0  : 192.168.20.1

Interface Serial2/0            : 192.168.1.2

Interface Serial3/0            : 192.168.2.1

 

Router 2

Interface FastEthernet0/0  : 192.168.30.1

Interface Serial2/0            : 192.168.2.2

Interface Serial3/0            : 192.168.3.1

 

Router 3 

Interface FastEthernet0/0  : 192.168.40.1

Interface Serial2/0            : 192.168.4.1

Interface Serial3/0            : 192.168.3.2

Selanjutnya setting IP address pada PC yang ada pada jaringan Router dengan cara memilih pada menu Desktop->Ip Configuration. Atur seperti gambar dibawah ini :

Lakukan hal yang sama pada semua PC yang akan disimulasikan.

Selanjutnya akan menkonfigurasi Router. Pada mengkonfigurasi adanya mode akses pada IOS Cisco

1. User EXEC Mode
– muncul pada saat pertama kali masuk
– akses ke router dibatasi
– hanya dapat melakukan ping dan melihat informasi dasar tentang router
– prompt pada mode ini ditandai dengan >, contoh : Router>
2. Privileged EXEC Mode :
– dapat melihat dan mengubah konfigurasi
– dapat melakukan perintah debugging
– prompt pada mode ini ditandai dengan #, contoh : Router#
3. Global Configuration Mode
– Untuk mengubah konfigurasi lebih lanjut dari router
– Untuk masuk ke mode ini ketikkan configure terminal pada Privileged EXEC Mode
– prompt pada mode ini ditandai dengan (config)#, contoh : Router(config)#
4. interface Configuration Mode
– dilakukan per-interface untuk kembali ke global configuration mode ketik exit
– prompt pada mode ini ditandai dengan (config-if)#, contoh : Router(config-if)#

Untuk menkonfigurasi pilih tab menu CLI di Router

Konfigurasi IP Address pada Interface FastEthernet0/0 Router seperti dibawah ini :

Untuk Konfigurasi Ip Address pada Interface Serial2/0 dan Interface Serial3/0 

Selanjutnya saya akan melakukan Konfigurasi Routing. Konfigurasi routing statis harus dilakukan pada masing-masing router untuk menentukan suatu jalur, pada contoh kasus ada 4 buah router, maka kita perlu mengonfigurasi keempatnya.
Perintah untuk memasukkan routing seperti berikut : ip route <network-address> <netmask> <next-hop> maka dalam contoh kasus Routing pada Router 0 adalah :

Lakukan hal yang sama pada Router 1, Router 2, Router 3 dengan konfigurasi:

Router 1 :

interface fa0/0
ip address 192.168.20.1 255.255.255.0
no shutdown
exit
interface se2/0
ip address 192.168.1.2 255.255.255.0
no shutdown
exit
interface se3/0
ip address 192.168.2.1 255.255.255.0
no shutdown
ip route 192.168.10.0 255.255.255.0 192.168.1.1
ip route 192.168.30.0 255.255.255.0 192.168.2.2
ip route 192.168.40.0 255.255.255.0 192.168.1.1

Router 2 :

Interface fa0/0
ip address 192.168.30.1 255.255.255.0
no shutdown
exit
interface se2/0
ip address 192.168.2.2 255.255.255.0
no shutdown
exit
interface se3/0
ip address 192.168.3.1 255.255.255.0
no shutdown
ip route 192.168.10.0 255.255.255.0 192.168.3.2
ip route 192.168.20.0 255.255.255.0 192.168.2.1
ip route 192.168.40.0 255.255.255.0 192.168.3.2

Router 3 :

interface fa0/0
ip address 192.168.40.1 255.255.255.0
no shutdown
exit
interface se2/0
ip address 192.168.4.1 255.255.255.0
no shutdown
exit
interface se3/0
ip address 192.168.3.2 255.255.255.0
no shutdown
ip route 192.168.10.0 255.255.255.0 192.168.4.2
ip route 192.168.20.0 255.255.255.0 192.168.3.1
ip route 192.168.30.0 255.255.255.0 192.168.3.1

Sedemikian hingga didapatkan Tabel Routing seperti dibawah ini :

 

No Comments

Simulasi Protocol Data Unit dalam Cisco Packet Tracer

Uncategorized

Kata “jaringan komputer” mungkin sudah tidak asing lagi pada era sekarang, mengingat hampir setiap hari tanpa disadari melibatkan jaringan komputer .Pada kali ini saya akan mencoba mensimulasikan protokol data unit pada suatu jaringan komputer yang pengaplikasiannya pada Cisco Paket Tracer. Pertama tama saya akan menjelaskan definisi dari jaringan komputer, protocol data unit (PDU) itu sendiri.

Jaringan Komputer adalah adalah jaringan telekomunikasi yang memungkinkan antar komputer untuk saling berkomunikasi dengan bertukar data. Tujuan dari jaringan komputer adalah agar dapat mencapai tujuannya, setiap bagian dari jaringan komputer dapat meminta dan memberikan layanan (service). Pihak yang meminta/menerima layanan disebut klien (client) dan yang memberikan/mengirim layanan disebut peladen (server). Desain ini disebut dengan sistem client-server, dan digunakan pada hampir seluruh aplikasi jaringan komputer.

Dua buah komputer yang masing-masing memiliki sebuah kartu jaringan, kemudian dihubungkan melalui kabel maupun nirkabel sebagai medium transmisi data, dan terdapat perangkat lunak sistem operasi jaringan akan membentuk sebuah jaringan komputer yang sederhana. Apabila ingin membuat jaringan komputer yang lebih luas lagi jangkauannya, maka diperlukan peralatan tambahan seperti Hub , Switch, Router sebagai peralatan interkoneksinya.

PDU merupakan singkatan dari Protocol Data Unit. PDU merupakan unit atau satuan dari data yang dikirimkan antar entitas di suatu jaringan yang bisa berupa informasi kontrol, informasi alamat atau data pengguna. Sedangkan Cisco Packet Tracer merupakan aplikasi yang memungkinkan kita membuat simulasi dari suatu jaringan komputer

Untuk membuat suatu simulasi jaringan pertama tama kita menyiapkan file baru di Cisco Paket Tracer.

Kemudian pilih End Device untuk menambahkan PC untuk mensimulasikan jaringan

Untuk menambahkan client pada sebuah jaringan pilih gambar PC dan Switch lalu drag ke lembar kerja sebanyak yang dibutuhkan, pada contoh kali ini saya mencoba 2PC pada suatu blok IP Address 

Sambungkan antar PC dengan switch

Tambahkan kabel straight sebagai penghubung antara switch dengan PC,ntuk pengaturan port PC0 berada di FastEthernet0/1 dan PC1 berada di FastEthernet0/2

Lakukan hal yang sama untuk penambahan pc dan switch sehingga membentuk sebuah jaringan seperti yang telah saya buat, saya membuat port yang menghubungkan antar switch pada fast ethernet3/0 dikedua switch tersebut, Lalu untuk  pc2 berada di fast ethernet0/1 dan pc2 berada di fast ethernet0/2 yang ada pada switch.

 

Pengaturan IP Address

Setelah kita menyiapkan beberapa device dan sudah dihubungkan dengan kabel, selanjutnya kita akan setting atau mengkonfigurasi IP Address nya pada tiap PC dan juga switchnya.
Cara setting-nya itu yang pertama, klik 2 kali device mana yang akan di setting IP Addressnya. Dalam hal ini kita akan setting IP Address yang PC 0 .

Double klik di pc yang akan di konfigurasi pada contoh kali ini saya menggunakan PC 0 untuk pengaturan IP address.Jika sudah klik 2 kali pada device tersebut, maka muncullah tampilan seperti gambar di atas. Selanjutnya kita klik Desktop.

Setelah itu pilih IP configuration untuk mengkonfigurasi IP pada pc 0

Sebagai contoh saya memasukan konfigurasi Alamat IP adalah

PC 0       : IP Address = 200.100.10.10

                : Subnet Mask = 255.255.248.0

 

Untuk pengaturan Alamat IP PC yang lain saya menggunakan Alamat IP sebagai berikut ;

PC 1       : IP Address = 200.100.10.11

                : Subnet Mask = 255.255.248.0

PC 2       : IP Address = 200.100.11.10

                : Subnet Mask = 255.255.248.0

PC 3       : IP Address = 200.100.11.11

                : Subnet Mask = 255.255.248.0

 

Pengecekan Jaringan

Setelah memlakukan konfigurasi maka kita perlu adanya pengecekan apakah jaringan yang telah dibuat bisa saling berinterkoneksi.

Cara mengeceknya pertama kita klik Add Simple PDU (Gambar Surat), kemudian arahkan PC awal dan PC akhir/tujuan yang akan dicoba untuk pengecekan.

Sebagai contoh saya mencoba melakukan pengecekan dari PC0 ke PC3, untuk mengetahui apakah sudah berhasil atau belum Lihat di Last Status apabila Last Status merupakan Successful maka jaringan sudah berhasil berinterkoneksi.

Kita lihat pada simulasi yang ada pada Cisco Paket Tracer

Setelah itu akan muncul event seperti ini

Double-click kotak berwarna pada kolom Info, maka akan muncul informasi PDU seperti berikut.

 

 

Dari simulasi diatas kita dapat mengetahui pengiriman PDU dari PC0 ke PC 1 pada Layer 1/Physical Layer terdapat port yang digunakan. Yang digunakan pada jaringan ini adalah port FastEthernet pada PC0,Pada Layer 2/Data Link Layer terdapat alamat fisik/MAC Address yang menjadi sumber dan tujuan

Mungkin hanya itu saja pembahasan yang dapat saya sampaikan. Mohon maaf jika masih ada salah karena saya juga masih belajar. Terima kasihhh 

No Comments

Penerapan Kecerdasan Buatan pada Masa Kini dan Masa yang akan Datang

Uncategorized

Kemajuan teknologi yang terus berkembang dapat dimanfaatkan manusia dalam berbagai bidang, termasuk dalam dunia kesehatan yang telah membawa dampak positif terhadap peningkatan kualitas pelayanan terhadap masyarakat. Kecerdasan Buatan merupakan teknologi yang mensimulasikan kecerdasan manusia yang mendefinisikan dan mencoba menyelesaikan persoalan menggunakan komputer dengan meniru bagaimana manusia menyelesaikan masalah dengan cepat.

Penelitian yang dilakukan Ting-Sheng Weng dan Chien-Hung Kuo pada tahun 2009 dengan judul “Development and Research on the Intelligent Emergency Medical Information System: A Case Study of Yunlin and Chiayi Counties in Taiwan ”, merupakan salah satu aplikasi yang sangat membantu pasien untuk mempercepat dan mempermudah dalam mendapatkan pelayanan serta membantu tenaga medis untuk melaksanakan tugasnya dengan cepat dalam menangani pasien.

Dalam penelitian tersebut di ciptakan sebuah aplikasi sistem infomasi darurat dalam menangani pasien secara cerdas di suatu daerah. Dimana jika terjadi kecelakaan ataupun pasien yang ingin ke sebuah rumah sakit di daerah tersebut dengan mudah dan cepat dapat ditunjukkan oleh sistem ini atau akan meningkatkan kecepatan dan pelayanan ambulan dalam membantu pelayanan darurat medis serta efisien waktu tempuh untuk menemukan posisi rumah sakit terdekat dengan pasien yang membutuhkan pelayanan.

Sistem dirancang untuk membantu memecahkan masalah antara pasien dengan tenaga medis/rumah sakit. Dalam sistem ini, diciptakan sebuah tugas fungsi darurat penyelamatan medis. Sistem ini menggunakan peta satelit Formosa 2 (FORMOSAT-2) dan teknologi Ajax untuk mengakses informasi terhadap peta dan memungkinkan operator pusat untuk menentukan lokasi yang benar dari pasien secara tepat waktu.
Berdasarkan lokasi pasien, kemudian ambulans akan mengetahui posisi pasien dari layanan. Kemudian, teknisi medis darurat sejalan penyelamatan pertama yang menggunakan perangkat mobile pasien atau smart phone dapat terhubung ke sistem melalui GPRS (General Packet Radio Service ) atau 3G (Third Generation Wireless Format) untuk mencari pasien. Akhirnya, teknisi medis darurat bisa memasukkan kondisi pasien ke dalam sistem, dan kemudian sistem akan menentukan rujukan rumah sakit mana yang paling tepat.

Penelitian yang telah dilakukan tersebut bertujuan untuk meningkatkan kemungkinan bahwa pasien menerima pengobatan yang tepat, dan disesuaikan untuk mengurangi pemborosan waktu yang disebabkan oleh transportasi yang tidak perlu antara rumah sakit. Sistem ini merupakan pengint¬¬¬egrasian sistem informasi rumah sakit dengan menggunakan ASP berbasis Web. Aplikasi mobile, dan bahasa teknologi Ajax, JavaScript dan SQL untuk membuat suatu sistem cerdas untuk informasi medis darurat yang menggabungkan aplikasi web, peta satelit dan fungsi keputusan darurat medis mobile. Diharapkan dengan menggunakan sistem ini, akan dapat meningkatkan efisiensi transportasi pasien di rumah sakit.

Perkembangan kecerdasan buatan tidak hanya selesai hingga pada saat ini namun akan terus berkembang hingga masa yang akan datang dimana teknologi tentunya akan jauh lebih berkembang pesat, pada bidang kedokteran sendiri sekarang sudah dikembangkan adalah mendiagnosa penyakit melalui iris mata, adanya gangguan atau penurunan fungsi organ tubuh direfleksikan pada iris mata dalam bentuk perubahan struktur anyaman serabut saraf iris mata yang dikenal dengan iridologi. Dalam dunia kedokteran, iridologi adalah ilmu yang mempelajari iris mata melalui perubahan warna, rupa, bentuk, dan simbol yang terdapat pada bagian mata. Iridologi merupakan general check-up yang bersifat kuantitatif yang bisa dilakukan secara kilat, tanpa rasa sakit, mudah, dan biaya yang di perlukan tak terlampau mahal.

Pada awalnya pemantauan iris mata dilakukan secara manual. Praktisi iridologi biasanya hanya melihat langsung mata pasien dengan alat bantu semacam senter atau sorotan cahaya. Namun pengamatan manual bisa berakibat salah diagnosis. Seiring dengan adanya pengembangan teknologi, dibuatlah suatu perangkat lunak bernama LIPIRISm@ yang merupakan program buatan anak bangsa yang memudahkan proses pengamatan iris mata sesuai dengan kaidah iridologi
Diagnosis dengan iridologi diklaim lebih unggul dalam menemukan adanya kelemahan organ dibanding pemeriksaan laboratorium.Hasilnya dapat diketahui secara real time sebagai perbandingan, untuk general check-up, pasien harus melewati sederet pemeriksaan: periksa darah, air seni, feses, roentgen, dan sebagainya. Tes laboratorium juga memakan waktu cukup lama dan memerlukan biaya yang cukup mahal.

Program ini dikembangkan mulai 2006 sampai akhir 2008 dengan bahasa pemrograman Delphi yang berorientasi objek.dan masih dalam tahap pengembangan program, program ini dapat menjadi salah satu implementasi kecerdasan buatan pada masa depan. Dengan adanya perkembangan teknologi dan perangkat yang akan semakin mendukung. Program ini dapat dikembangkan untuk mendeteksi gangguan lainnya selain saraf, sehingga dapat membantu memprediksi seseorang tersebut rentan terhadap suatu gannguan tubuh lainnya.Pada masa kini program ini hanya dapat mendiagnosa penyakit secara kuantitatif namun diagnosa dapat terus berkembang hingga diketahui tingkat keparahan penyakit (akut, subakut, kronis dan degenaratif).

No Comments

Pembangunan Knowledge Management System pada server cs.upi.edu

Uncategorized

Saya Arin Fitrianda dari kelompok 2 mata kuliah Rekayasa Perangkat Lunak,saya disini akan menarasikan proyek yang akan kami bangun,Kelompok kami akan membangun Aplikasi Berbasis Web yaitu KMS (Knowledge Management System) adalah sistem yang diciptakan untuk memfasilitasi penangkapan, penyimpanan, pencarian, pemindahan dan penggunaan kembali pengetahuan.

Tujuan utama dari KMS adalah untuk mendukung dinamika pembelajaran dan keefektifan mata kuliah tersebut dibutuhkan sistem khusus yang ditujukan untuk mengolah Knowledge Sistem ini akan dibuat pada server cs.upi.edu.

Kelompok kami dalam pembangunan proyek KMS akan dipantau oleh kelompok mata kuliah Managemen Proyek Perangkat Lunak yaitu Haikal Adha H sebagai Manajer Proyek, Agung Cahya Gumilar sebagai Ketua divisi yang menangani front end, Lingga Setyagusti sebagai Ketua divisi yang menangani back end, Velina Rehulina Nanjar Hayati sebagai Ketua divisi yang menangani arsitektur aplikasi,kami akan memulai pembangunan perangkat lunak pada tanggal 1 Maret 2017  sampai dengan 30 April 2017  dengan estimasi dana awal dikeluarkan sebesar Rp.5.000.000,00.

Metode pengembangan perangkat lunak yang akan kami pakai yaitu metode scrum dimana  pengembangan perangkat lunak kerangka kerja tambahan tangkas untuk proyek perangkat lunak dan mengelola produk atau pengembangan aplikasi, metode ini cocok diimplementasikan pada proyek yang akan kami bangun karena dilihat dari aplikasi masih tahap pengembangan jadi apabila ada perubahan dalam masa pembangunan akan lebih mudah mengubah aplikasi tersebut, waktu pengerjaan yang singkat,ruang lingkup kelompok yang kecil serta komunikasi yang lebih mudah karena tim kami berada di ruang lingkup ilmu komputer

Pada awal pembangunan aplikasi kami akan menganalisis kebutuhan alokasi server pada cs.upi.edu untuk aplikasi dengan harapan kami bisa menentukan apa saja yang akan dibutuhkan oleh pengguna aplikasi tersebut dengan dibangunnya sistem ini harapannya  dapat mengakomodir kegiatan pembelajaran secara online berupa forum diskusi dengan satu orang berperan sebagai pengajar(lecturer) yang dianggap mampu untuk mengampu topik dan pokok bahasan kegiatan tersebut.

Juga diharapkan aplikasi tersebut dapat menjadi tempat para user untuk menjadi sarana penyaluran ide berupa dialog, file, atau instrumen lainnya yang dapat direspon dengan berbagai cara oleh user lainnya,

No Comments

Hello world!

Uncategorized

Welcome to Blog Civitas UPI. This is your first post. Edit or delete it, then start blogging!

1 Comment